トップページ -> プログラミング -> Ruby プログラミング -> Windows で Ruby のインストール (Ruby バージョン 1.9 系列)
[サイトマップへ], [サイト内検索へ]

Windows で Ruby のインストール (Ruby バージョン 1.9 系列)

この Web ページでは Windows での Ruby のインストール手順を説明する.

RubyGems と Rake は,ruby バージョン 1.9.1 には標準で組み込まれています.

Exerb, VisualuRuby, Graff などを用いたい場合にはバージョン 1.8 系列をすすめます(2010/1 時点).

Ruby プログラミング用の開発環境として,emacs のようなエディタを使用するか, 開発環境を使うことを薦めます

Ruby on Rails や Ruby を使ったデータベースプログラミングなどは,別の Web ページで説明している.

参考 Web ページ: http://www.gfd-dennou.org/arch/davis/gfdnavi/doc/install/install-rails.htm


前もって決めておく事項


Ruby のインストール

  1. Ruby の Web ページを開く

    http://www.ruby-lang.org/ja/

  2. ダウンロード」をクリック

    [image]
  3. 下の方にある FTP ミラーサイトの中から日本のミラーサイト」を 1つ選び,クリック

    [image]
  4. binaries」をクリック

    [image]
  5. MSwin 版のバイナリが欲しいので 「mswin32」をクリック

    [image]
  6. 最新の安定版のファイルをクリック

    ※ unstable は安定板ではないが最新機能を試したいときなどは便利.

    ※ 32 ビットの windows は mswin32

    [image]
  7. ダウンロードが始まる
  8. Ruby のインストールディレクトリ C\ruby-1.9 を作成

    [image]
  9. ダウンロードした ZIP ファイルを,Ruby のインストールディレクトリ C\ruby-1.9 に解凍

    [image]
  10. Windows の環境変数 PATH の設定

    Windows の環境変数PATH」に「C:\ruby-1.9\bin」を追加

    [image]

OpenSSL for Windows のインストール

  1. OpenSSL の Windows 版バイナリの Web ページを開く http://www.openssl.org/related/binaries.html
  2. OpenSSL for Windows」をクリック

    [image]
  3. この Web ページにある 「Visual C++ 2008 Redistributables」をクリックし,ダウンロードし,インストールする
  4. Win32 OpenSSL v0.9.8k」をクリック ※ 64 ビット Windows を使っている場合には Win64 の方になる.

    [image]
  5. ダウンロードが始まる
  6. ダウンロードしたファイルを実行する
  7. ようこそ画面

    Next」をクリック

    [image]
  8. ライセンス条項

    ライセンス条項を確認し,納得した上で「I accept the agreement」をチェックし, 「Next」をクリック

    [image]
  9. インストール・ディレクトリの設定

    デフォルトのままでよい. 「Next」をクリック

    [image]
  10. スタートメニューフォルダーの設定

    デフォルトのままでよい. 「Next」をクリック

    [image]
  11. 追加タスクの設定

    「The Windows system directory」にチェックされたままでよい. 「Next」をクリック

    [image]
  12. インストール開始

    インストールを開始したいので, 「Install」をクリック

    [image]
  13. インストールが始まる

    インストールを開始したいので, 「Install」をクリック

    [image]
  14. 寄付の画面が出るので,賛同し納得の上,各自の負担で寄付をする(各自の責任で判断すること).

Zlib for Windows のインストール

  1. Zlib for Windows の Web ページを開く http://gnuwin32.sourceforge.net/packages/zlib.htm
  2. Complete package, except sources」の右横の「Setup」をクリック

    [image]
  3. ダウンロードが始まる
  4. ダウンロードしたファイルを実行する
  5. ようこそ画面

    Next」をクリック

    [image]
  6. ライセンス条項

    ライセンス条項を確認し,納得した上で「I accept the agreement」をチェックし, 「Next」をクリック

    [image]
  7. インストール・ディレクトリの設定

    デフォルトのままでよい. 「Next」をクリック

    [image]
  8. コンポーネントの選択

    「Full installation」(デフォルト)のままでよい. 「Next」をクリック

    [image]
  9. スタートメニューフォルダーの設定

    デフォルトのままでよい. 「Next」をクリック

    [image]
  10. 追加タスクの設定

    デフォルトのままでよい. 「Next」をクリック

    [image]
  11. インストール開始

    インストールを開始したいので, 「Install」をクリック

    [image]
  12. インストールの完了

    Finish」をクリック

    [image]
  13. C:\Program Files\GnuWin32\zlib1.dll を C:\Program Files\GnuWin32\zlib.dllという名前でコピー

    [image]
  14. Windows の環境変数 PATH の設定

    Windows の環境変数PATH」に「C:\Program Files\GnuWin32\bin」を追加

    [image]

Ruby on Rails を gem でインストール

以下の操作は Windows のコマンドプロンプトで行う.

  1. gem install rails --include-dependencies」の実行

    ■ 安定版をインストールした場合(普通はこちら)

    gem install pkg-config --include-dependencies
    gem install rails --include-dependencies
    

    [image]

    数分待つ.途中で止まっているように見えるかも知れないが待つこと.

    ■ Ruby on Rails バージョン 3 (プレリリース版) をインストールした場合(最新の機能を試したい場合はこちら)

    gem install tzinfo builder i18n memcache-client rack rake rack-test rack-mount erubis mail text-format thor bundler --include-dependencies
    gem install rack-mount --version=0.4.7
    gem install rails --prerelease --include-dependencies
    

    数分待つ.途中で止まっているように見えるかも知れないが待つこと.

  2. インストール終了の確認

    [image]

    (オプション) Ruby Facets を gem でインストール

    1. NYACUS コマンドラインシェルを起動

      Windows の「スタート」から「Rumix」を選び,「NYACUS (コマンドラインシェル)」を選ぶ

    2. 「gem install facets --include-dependencies 」の実行
      gem install facets --include-dependencies
      
    3. テスト実行
      irb
      require 'rubygems'
      require 'facets'
      p Time.elapse { sleep 0.12345 }
      

    (オプション)Ruby の gem で MySQL パッケージ, SQLite3 パッケージをインストール

    以下の操作は Windows のコマンドプロンプトで行う.

    1. gem install mysql --include-dependencies」の実行

      ※ Ruby 用の MySQL パッケージをインストールしたいとき

      [image]
    2. インストール終了の確認

      エラーメッセージが出ていないことを確認する.

      [image]
    3. gem install sqlite3-ruby --include-dependencies」の実行

      ※ Ruby 用の MySQL パッケージをインストールしたいとき

      [image]
    4. インストール終了の確認

      エラーメッセージが出ていないことを確認する.

      [image]

    本サイトは金子邦彦研究室のWebページです.サイトマップは,サイトマップのページをご覧下さい. 本サイト内の検索は,サイト内検索のページをご利用下さい.

    問い合わせ先: 金子邦彦(かねこ くにひこ) [image]